
<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">

<head>
		<meta charset="UTF-8" />
	<!-- wp_head -->
	<title>Small Town Living A happy haven for many - Delta Business Journal</title>

<!-- This site is optimized with the Yoast SEO plugin v6.0 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://deltabusinessjournal.com/small-town-living-happy-haven-many/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Small Town Living A happy haven for many - Delta Business Journal" />
<meta property="og:description" content="By MARK H. STOWERS Though many have been bypassed others have withered to a small portion of their former stature, Delta small towns once thrived and were stand-alone entities with their own economies and idiosyncrasies. Farming communities that thrived with cotton have shifted to other crops to sustain themselves and the rich Delta land. Drew &hellip;" />
<meta property="og:url" content="http://deltabusinessjournal.com/small-town-living-happy-haven-many/" />
<meta property="og:site_name" content="Delta Business Journal" />
<meta property="article:publisher" content="https://www.facebook.com/DeltaBusinessJournal" />
<meta property="article:section" content="Featured Articles" />
<meta property="article:published_time" content="2018-01-05T13:50:56-06:00" />
<meta property="og:image" content="http://deltabusinessjournal.com/wp-content/uploads/2018/01/Small-Town-Living.jpeg" />
<meta property="og:image:width" content="1162" />
<meta property="og:image:height" content="784" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="By MARK H. STOWERS Though many have been bypassed others have withered to a small portion of their former stature, Delta small towns once thrived and were stand-alone entities with their own economies and idiosyncrasies. Farming communities that thrived with cotton have shifted to other crops to sustain themselves and the rich Delta land. Drew [&hellip;]" />
<meta name="twitter:title" content="Small Town Living A happy haven for many - Delta Business Journal" />
<meta name="twitter:image" content="http://deltabusinessjournal.com/wp-content/uploads/2018/01/Small-Town-Living.jpeg" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/deltabusinessjournal.com\/","name":"Delta Business Journal","potentialAction":{"@type":"SearchAction","target":"http:\/\/deltabusinessjournal.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Delta Business Journal &raquo; Feed" href="http://deltabusinessjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Delta Business Journal &raquo; Comments Feed" href="http://deltabusinessjournal.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/deltabusinessjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='themify-common-css'  href='http://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/css/themify.common.min.css?ver=4.9.1' type='text/css' media='all' />
<meta name="themify-framework-css" content="themify-framework-css" id="themify-framework-css">
<meta name="builder-styles-css" content="" id="builder-styles-css">
<link rel='stylesheet' id='theme-style-css'  href='http://deltabusinessjournal.com/wp-content/themes/themify-ultra/style.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='themify-media-queries-css'  href='http://deltabusinessjournal.com/wp-content/themes/themify-ultra/media-queries.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='themify-customize-css'  href='http://deltabusinessjournal.com/wp-content/uploads/themify-customizer.css?ver=17.06.15.12.55.01' type='text/css' media='all' />
<link rel='stylesheet' id='themify-google-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A400italic%2C600italic%2C700italic%2C400%2C300%2C600%2C700&#038;subset=latin&#038;ver=4.9.1' type='text/css' media='all' />
<script type='text/javascript' src='http://deltabusinessjournal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://deltabusinessjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://deltabusinessjournal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://deltabusinessjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://deltabusinessjournal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.1" />
<link rel='shortlink' href='http://deltabusinessjournal.com/?p=768' />
<link rel="alternate" type="application/json+oembed" href="http://deltabusinessjournal.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdeltabusinessjournal.com%2Fsmall-town-living-happy-haven-many%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://deltabusinessjournal.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdeltabusinessjournal.com%2Fsmall-town-living-happy-haven-many%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":768,"post_name":"small-town-living-happy-haven-many","post_title":"Small Town Living  A happy haven for many","post_type":"post","post_author":"5","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":8,"name":"Featured Articles","slug":"featured-articles","term_group":0,"term_taxonomy_id":8,"taxonomy":"category","description":"","parent":0,"count":37,"filter":"raw","cat_ID":8,"category_count":37,"category_description":"","cat_name":"Featured Articles","category_nicename":"featured-articles","category_parent":0}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"deltabus-ca","ID":5};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="173014" async></script>



<script type="text/javascript">
    window.heap=window.heap||[],heap.load=function(e,t){window.heap.appid=e,window.heap.config=t=t||{};var r=t.forceSSL||"https:"===document.location.protocol,a=document.createElement("script");a.type="text/javascript",a.async=!0,a.src=(r?"https:":"http:")+"//cdn.heapanalytics.com/js/heap-"+e+".js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(a,n);for(var o=function(e){return function(){heap.push([e].concat(Array.prototype.slice.call(arguments,0)))}},p=["addEventProperties","addUserProperties","clearEventProperties","identify","removeEventProperty","setEventProperties","track","unsetEventProperty"],c=0;c<p.length;c++)heap[p[c]]=o(p[c])};
      heap.load("255883404");
</script>
<meta name="google-site-verification" content="QsDs463dxODSgT8rStvSwfYtv5EFerXLC_iInYcMEFA" />	<script type="text/javascript" defer>
		var tf_mobile_menu_trigger_point = 1200;
	</script>
<meta name="viewport" content="width=device-width, initial-scale=1">

	<style>
	@-webkit-keyframes themifyAnimatedBG {
		0% { background-color: #33baab; }
100% { background-color: #e33b9e; }
50% { background-color: #4961d7; }
33.333333333333% { background-color: #2ea85c; }
25% { background-color: #2bb8ed; }
20% { background-color: #dd5135; }

	}
	@keyframes themifyAnimatedBG {
		0% { background-color: #33baab; }
100% { background-color: #e33b9e; }
50% { background-color: #4961d7; }
33.333333333333% { background-color: #2ea85c; }
25% { background-color: #2bb8ed; }
20% { background-color: #dd5135; }

	}
	.themify_builder_row.animated-bg {
		-webkit-animation: themifyAnimatedBG 30000ms infinite alternate;
		animation: themifyAnimatedBG 30000ms infinite alternate;
	}
	</style>
	<!-- BEGIN GADWP v5.1.2.5 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-96540291-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->

</head>

<body class="post-template-default single single-post postid-768 single-format-standard themify-fw-3-3-9 themify-ultra-1-9-1 skin-default not-ie default_width sidebar1 no-home no-touch builder-parallax-scrolling-active header-block fixed-header shrinking-logo footer-block default tagline-off rss-off search-off single-classic-layout tile_enable  filter-hover-none filter-featured-only masonry-enabled">

<script type="text/javascript">
	function themifyMobileMenuTrigger(e) {
		if( document.body.clientWidth <= tf_mobile_menu_trigger_point ) {
			document.body.classList.add( 'mobile_menu_active' );
		} else {
			document.body.classList.remove( 'mobile_menu_active' );
		}
	}
	themifyMobileMenuTrigger();
	document.addEventListener( 'DOMContentLoaded', function () {
		jQuery( window ).on('tfsmartresize.tf_mobile_menu', themifyMobileMenuTrigger );
	}, false );
</script>

<div id="pagewrap" class="hfeed site">

			<div id="headerwrap"   >
                        			                                                    <div class="header-icons">
                                <a id="menu-icon" href="#mobile-menu"></a>
                            </div>
                        
			<header id="header" class="pagewidth clearfix" itemscope="itemscope" itemtype="https://schema.org/WPHeader">

	            
	            <div class="header-bar">
		            						<div id="site-logo"><a href="http://deltabusinessjournal.com" title="Delta Business Journal"><img src="http://deltabusinessjournal.com/wp-content/uploads/2017/03/Delta-Business-Journal-Logo.png" alt="Delta Business Journal" title="Delta Business Journal" /></a></div>					
									</div>
				<!-- /.header-bar -->

									<div id="mobile-menu" class="sidemenu sidemenu-off">

						<div class="navbar-wrapper clearfix">

															<div class="social-widget">
																												
																	</div>
								<!-- /.social-widget -->
							
							
							<nav id="main-nav-wrap" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
																	<ul id="main-nav" class="main-nav menu-name-primary"><li id='menu-item-155' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home" ><a  href="http://deltabusinessjournal.com/">Home</a> </li>
<li id='menu-item-26' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/about-delta-business-journal/">About DBJ</a> </li>
<li id='menu-item-105' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/subscribe/">Subscribe</a> </li>
<li id='menu-item-24' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/contact-us/">Contact Us</a> </li>
<li id='menu-item-458' class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children has-sub-menu has-sub-menu" ><a >Archives</a> 
<ul class="sub-menu">
<li id='menu-item-470' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/cover-stories/">Cover Stories</a> </li>
<li id='menu-item-469' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/feature-stories/">Features</a> </li>
<li id='menu-item-484' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/from-the-publisher/">From the Publisher</a> </li>
<li id='menu-item-483' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/guest-column/">Guest Columns</a> </li>
<li id='menu-item-467' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/latest-news/">Latest News</a> </li>
<li id='menu-item-492' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/question-and-answer/">Q&#038;A</a> </li>
<li id='menu-item-468' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/viewpoints/">Viewpoints</a> </li>
</ul>
</li>
<li id='menu-item-25' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/media-kit/">Media Kit</a> </li>
<li id='menu-item-126' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="http://deltabusinessjournal.com/business-brief/">Business Brief</a> </li>
</ul>									<!-- /#main-nav -->
									
																		
															</nav>
							<!-- /#main-nav-wrap -->
							
						</div>

																				<!-- /header-widgets -->
						
						<a id="menu-icon-close" href="#"></a>
					</div>
					<!-- /#mobile-menu -->
				
				
				
				
			</header>
			<!-- /#header -->

	        
		</div>
		<!-- /#headerwrap -->
	
	<div id="body" class="clearfix">

		

	
	<!-- layout-container -->
	<div id="layout" class="pagewidth clearfix">

		
		<!-- content -->
		<div id="content" class="list-post">
			
			
				

<article id="post-768" class="post clearfix post-768 type-post status-publish format-standard has-post-thumbnail hentry category-featured-articles has-post-title has-post-date no-post-category has-post-tag no-post-comment no-post-author   cat-8">
	
            <a href="http://deltabusinessjournal.com/small-town-living-happy-haven-many/" data-post-permalink="yes" style="display: none;"></a>
    
	
	
	
		
			<figure class="post-image  clearfix">

									<a href="http://deltabusinessjournal.com/small-town-living-happy-haven-many/"><img src="http://deltabusinessjournal.com/wp-content/uploads/2018/01/Small-Town-Living-1024x691-275x400.jpeg" width="275" height="400" class=" wp-post-image wp-image-769" alt="Small Town Living" /></a>
				
			</figure>

		
	
	
	<div class="post-content">
		<div class="post-content-inner">

							<div class="post-date-wrap post-date-inline">
					<time class="post-date entry-date updated" datetime="2018-01-05">
                                                                                            <span class="year">January 5, 2018</span>
                                            					</time>
				</div>
			
							 <h1 class="post-title entry-title"><a href="http://deltabusinessjournal.com/small-town-living-happy-haven-many/">Small Town Living  A happy haven for many</a> </h1>			
							<p class="post-meta entry-meta">
					
					
																
									</p>
				<!-- /post-meta -->
			
			
			<div class="entry-content">

				
					<p class="p1">By MARK H. STOWERS</p>
<p class="p1">Though many have been bypassed others have withered to a small portion of their former stature, Delta small towns once thrived and were stand-alone entities with their own economies and idiosyncrasies. Farming communities that thrived with cotton have shifted to other crops to sustain themselves and the rich Delta land.</p>
<p class="p1">Drew</p>
<p class="p1">The Home of Archie Manning</p>
<p class="p1">Founded in 1899, Drew, Mississippi once had an excess of 13 cotton gins in town and a population over 2,600 residents. The North Sunflower County rich farmland produced mostly cotton for generations but now rice, soybeans and corn demand the acreage and there’s not a single cotton gin left in the town. Most folks only know Drew as the hometown of Ole Miss and NFL quarterback Archie Manning. These days the population is around 2,400 or so.</p>
<p class="p1">Stafford Shurden, a life-long Drew native who is a judge, farmer, restaurateur and entrepreneur has seen his home town thrive and regenerate over the years.</p>
<p class="p1">“There’s not much retail business there but there is a small grocery store coming soon,” Shurden says. “There’s a law office where Archie Manning’s mom worked for years. We have a couple of gas stations, a NAPA store, Mississippi Rice and Grain a rice dryer and my business—Stafford’s Market and Deli and I have 1933 Catering.”</p>
<p class="p1">Mayor Harvey Burchfield is in his first term serving the town and is determined to keep the small town moving forward.</p>
<p class="p1">“If God gives us a vision, He will provide for that vision,” Mayor Burchfield says. “I’m trusting God and standing on His word. To me, a mayor’s job is not different than a preacher, pastor, bishop, apostle—my job is to serve the people.”</p>
<p class="p1">The scripture spewing mayor stands on the Word of God to push the small town toward positive things.</p>
<p class="p1">“We are excited about the growth of Drew. Psalm 118:17 says, ‘I shall not die but live and declare the works of the Lord.’ Drew shall not die. Drew shall live. We will continue to work hard with the people and stay focused on what we can do for our city,” he says. “My motto is ‘moving forward so we can get ahead.’”</p>
<p class="p1">Rosedale</p>
<p class="p1">River Ready</p>
<p class="p1">Colonel Lafayette Jones came to the area in 1855, settled down and built a home and named it Rosedale after his family’s Virginia estate. Incorporated in 1882, three aldermen and marshal were elected. The port city got electricity in 1902 and through the selling of bonds continued improving the city from sidewalks to drinking water. Today, the town has 1,800 plus residents (2010 census). Former Arkansas senator Percy Malone was raised in Rosedale before moving to Arkansas.</p>
<p class="p1">The Port of Rosedale has continued to bring traffic to town—via the Mississippi River. The Port of Rosedale was built in the mid 1970s and now has cargo docks to load and unload, towing capabilities, warehouse space and much more. Existing industries from grease and lubricant manufacturer, liquid fertilizer, several grain terminals, a towing company and asphalt paving company. The port sits at the juncture of the Mississippi River and the mouth of the Arkansas River.</p>
<p class="p1">Each Delta town has plenty of good eating and Rosedale is now different. With Dino’s Grocery run by Joey Lamb, hungry diners can find a big city flavor in this out of way location. Lamb has a culinary arts degree and a decade of Nashville restaurant experience before coming home.</p>
<p class="p1">“I’ve been open for a year and a half but the building has been Leah’s on the Levee and the Blue Levee—both times owned by a Rosedale resident as well,” Lamb says. “I named it after my late older brother.”</p>
<p class="p1">The 125- to 135-person restaurant has live music and is supported by local farmers, hunters behind the levee and plenty of local folks who enjoy Lamb’s hometown flavor mixed with culinary twists.</p>
<p class="p1">Rolling Fork</p>
<p class="p1">Home of the Teddy Bear</p>
<p class="p1">First settled in 1828, the town’s name came from the rolling water that came through the fork in Deer Creek there. Today, the small town located on Highway 61 has more than 2,400 residents (2010 census). Mayor Fred Miller noted Rolling Fork is known for the beginning of the Teddy Bear.</p>
<p class="p1">“President Theodore Roosevelt came to have his famous bear hunt in Rolling Fork,” Mayor Miller says. “Because he did not kill the bear there was a political cartoon of the president walking away from a small bear. A toymaker asked if he could make a bear calling it Teddy’s Bear.”</p>
<p class="p1">The bear is celebrated with a Blues Festival each year and it brings “a fair amount of tourism.” There’s also the nation’s largest “all bottom land timber national forest—the Delta National Forest. It’s all hardwoods,” Mayor Miller says.</p>
<p class="p1">Famous blues man Muddy Waters was born in Rolling Fork and went by McKinley Morganfield before changing it.</p>
<p class="p1">The mayor dubbed Rolling Fork “the nicest small town in the Delta. And about 10 years ago we started doing a recreation of a love story—’Mont Helena—A Dream Revisited.’ It’s a true story about a couple that was engaged and the young man gets killed in a duel.”</p>
<p class="p1">The town has three doctors, a hospital, a dentist, rehab facility, a dialysis unit and a community bank—The Bank of Anguilla.</p>
<p class="p1">“The bank is small—about $150 million and I’m the Chairman of the Board of the Bank having worked their 47 years before I retired,” he says. “</p>
<p class="p1">Embedded in the town’s history is Chucks Dairy Bar for more than 40 years and is now owned by Tracy Harden who worked for the original owner—Charles “Chuck” Henderson.</p>
<p class="p1">“We are known for the Chucksburger that consists of a large hamburger patty, coleslaw, chili, mayo, mustard and pickles. But you would also need to try our fried strip steak basket and a large chocolate shake,” Harden says.<span class="Apple-converted-space">  </span>“Chuck’s offers a full breakfast menu, a daily plate lunch, as well as a full lunch and supper menu. Chuck’s is a meeting place for any and everyone. And when the Mayor’s wife tells him he’s having hamburger steak for supper, he knows he’s having Chuck’s,” she says.</p>
<p class="p1">Itta Bena</p>
<p class="p1">Home in the Woods</p>
<p class="p1">The Choctaw Indians were the first residents of this Leflore County town that Highway 7 runs through and is situated just off of Highway 82. But it was a state senator and later governor, Benjamin Grubb Humphreys who was given credit for founding this “Home in the Woods” town after he arrived via river boat steamer in 1846 looking for new farmland.</p>
<p class="p1">Today, the town of just over 2,000 residents is the home to Mississippi Valley State University (founded in 1950) along with America’s Catch Catfish and Scott Petroleum as the biggest employers in the area. Some small businesses like The Internet Café have found a niche but overall like many small Delta towns banks and grocery stores have closed or moved on to busier locations.</p>
<p class="p1">Solon Scott Jr., owns America’s Catch and Scott Petroleum and employs nearly 675 folks through the two entities. The life-long Itta Bena resident has seen the town grow and its contraction but he’s doing what he can to help sustain the area.</p>
<p class="p1">“I was born and raised here and my daddy bought this building back in 1932,” Scott says. “Daddy was in business here from 1932 on and started out as a mechanic shop then he moved into selling butane and building butane tanks.”</p>
<p class="p1">From there, Scott began distributing fuel and moved into the catfish industry in the 1980s.</p>
<p class="p1">“The good news is that the catfish industry came along and we employ about 350 people. And that has offset the loss of farm labor,” he says.</p>
<p class="p1">Itta Bena—Home in the Woods and surviving.</p>
<p class="p1">Moorhead</p>
<p class="p1">Where the Southern Crosses</p>
<p class="p1">the Yellow Dog</p>
<p class="p1">This Delta hamlet has ties to both Henry Ford and Thomas Edison as the town’s founder, Chester H. Pond—a profound clock maker and inventor—came here in the late 1800s. After working with Edison during his most productive years, Pond invented the self-winding clock and moved to Moorhead to invest in timber lands in 1895. Thanks to Pond, the world has time zones, fire alarm systems and the Delta has more trains. He actually built a 20-mile piece of track that connected Moorhead to Ruleville—the Yazoo Delta Railway—to move timber. By 1900 that piece of railroad line was incorporated into the Yazoo and Mississippi Valley Railroad—the “Yellow Dog.” The Southern Railway was the other railway that ran through the town.</p>
<p class="p1">The town grew from the popularity of two railroads actually dissecting the location at right angles—something rarely heard of. The Southern crossed the Yellow Dog—blues songs were sung and the town’s locale became somewhat famous. Sunflower Junior College would be founded in 1926 and accredited two years later. Today—now renamed twice—Mississippi Delta Junior College and then Mississippi Delta Community College—is the town’s largest employer drawing students from eight Delta area counties and beyond. The once vibrant railroad stop morphed into an agricultural town surrounded by cotton, soybeans, corn and catfish. Two of its famous former residents include the current governor of Mississippi, Phil Bryant and the late country singer and songwriter, Johnny Russell.</p>
<p class="p1">Anguilla</p>
<p class="p1">A Big Little Town</p>
<p class="p1">Named after the Vick family’s plantation Anguilla, Mississippi has a population of 661. The Mississippi Delta town does have its own independent bank—The Bank of Anguilla. Incorporated in 1913 and located on Deer Creek in Sharkey County, the town was originally named McKinneyville who first came to the area in 1869 but was changed after the railway was built through the town.</p>
<p class="p1">The president of the bank, Andy Anderson, grew up in Anguilla and has been at the bank for more than three decades.</p>
<p class="p1">“The town has a place to eat—The Maranto Brothers. They are known for their fried chicken. The main thing for Anguilla is hunting and recreation in the area,” Anderson says. “We do have a middle school and the bank.”</p>
<p class="p1">Hollandale</p>
<p class="p1">Another Highway 61 Treasure</p>
<p class="p1">The town was incorporated in 1890 but was almost totally destroyed by a fire in 1904. These days the town has 3,400 plus residents in the Washington County locale. Land deeds dated in 1823 were the earliest recorded for the area but Hollandale wasn’t incorporated until 1897 on the West side of Deer Creek. The fire destroyed all or part of 14 businesses but with insurance coverage, many were able to re-establish.</p>
<p class="p1">The city did have some excitement when pilot Charles Lindberg landed close by and gave rides for a dollar. This was just before his famous trip across the Atlantic Ocean.</p>
<p class="p1">Notable folks from Hollandale include blues legend Sam Chatmon who has a Mississippi Blues Trail Marker there. Ulis Williams, a 1964 Summer Olympic Gold Medal winner in the 4 x 400-meter relay is from Hollandale. The late Ben Peters who wrote #1 hit country songs for Charley Pride and others is also from the area.</p>
<p class="p1">Benoit</p>
<p class="p1">Home of the Baby Doll House</p>
<p class="p1">Hollywood came to town in 1956 to film at the Burrus House that dates back to 1859. The film “Baby Doll” was risqué for its time and garnered four Academy Award nominations as well as many others. The site is now owned by the Burrus Foundation and it is used for social events and other occasions.</p>
<p class="p1">“It’s on the Mississippi Historical Society Registry,” Mayor Ward says. “They also have cottages for rent there.”</p>
<p class="p1">Located on Highway 1 at the intersection of Highway 448, Benoit has nearly 500 residents and Mayor Calvin Ward noted there is virtually no crime and has a low tax base to entice businesses. The town boasts a bank—The Bank of Benoit, a parts store, a service station/convenience store and Scott Petroleum.</p>
<p class="p1">“The Bank of Benoit is our largest employer,” the mayor says.</p>
<p class="p1">Small Delta towns, each with a rich history and story or two to tell.</p>
<div id="themify_builder_content-768" data-postid="768" class="themify_builder_content themify_builder_content-768 themify_builder">

    </div>
<!-- /themify_builder_content -->
				
			</div><!-- /.entry-content -->

			
		</div>
		<!-- /.post-content-inner -->
	</div>
	<!-- /.post-content -->
	
</article>
<!-- /.post -->

			
			
			
			
			
			
					</div>
		<!-- /content -->

		
		    
    <aside id="sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSidebar">

        
	<div id="search-3" class="widget widget_search"><h4 class="widgettitle">Site Search</h4><form method="get" id="searchform" action="http://deltabusinessjournal.com/">

	<i class="icon-search"></i>

	<input type="text" name="s" id="s" title="Search" value="" />

</form></div><div id="nav_menu-2" class="widget widget_nav_menu"><h4 class="widgettitle">Quick Links</h4><div class="menu-sidebar-1-container"><ul id="menu-sidebar-1" class="menu"><li id="menu-item-474" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-474"><a href="http://deltabusinessjournal.com/cover-stories/">Cover Stories</a></li>
<li id="menu-item-473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-473"><a href="http://deltabusinessjournal.com/feature-stories/">Features</a></li>
<li id="menu-item-472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-472"><a href="http://deltabusinessjournal.com/viewpoints/">Viewpoints</a></li>
<li id="menu-item-471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471"><a href="http://deltabusinessjournal.com/latest-news/">Latest News</a></li>
</ul></div></div><div id="mc_mm_widget-5" class="widget widget_mc_mm_widget"><h4 class="widgettitle">Get the Brief</h4><div class='mailmunch-wordpress-widget mailmunch-wordpress-widget-224483' style='display: none !important;'></div></div>
        
    </aside>
    <!-- /#sidebar -->

    
	</div>
	<!-- /layout-container -->



        			</div>
			<!-- /body -->

							<div id="footerwrap"   >

					
					<footer id="footer" class="pagewidth clearfix" itemscope="itemscope" itemtype="https://schema.org/WPFooter">

						
													                            <div class="back-top clearfix ">
                                <div class="arrow-up">
                                    <a href="#header"></a>
                                </div>
                            </div>
                        
						<div class="main-col first clearfix">
							<div class="footer-left-wrap first">
																	<div class="footer-logo-wrapper clearfix">
										<div id="footer-logo"><a href="http://deltabusinessjournal.com" title="Delta Business Journal"><span>Delta Business Journal</span></a></div>										<!-- /footer-logo -->
									</div>
															
															</div>
							
							<div class="footer-right-wrap">

																	<div class="footer-nav-wrap">
																			</div>
									<!-- /.footer-nav-wrap -->
																									<div class="footer-text clearfix">
										<div class="footer-text-inner">
																							<div class="one">Copyright 2017 Delta Business Journal</div>																																	</div>
									</div>
									<!-- /.footer-text -->
															</div>
						</div>

																					<div class="section-col clearfix">
									<div class="footer-widgets-wrap">
																				<!-- /footer-widgets -->
									</div>
								</div>
													
						
					</footer>
					<!-- /#footer -->

					
				</div>
				<!-- /#footerwrap -->
			
		</div>
		<!-- /#pagewrap -->

		
		<!-- SCHEMA BEGIN --><script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"BlogPosting","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/deltabusinessjournal.com\/small-town-living-happy-haven-many\/"},"headline":"Small Town Living  A happy haven for many","datePublished":"2018-01-05T13:50:56+00:00","dateModified":"2018-01-05T13:50:56+00:00","author":{"@type":"Person","name":"deltabus-ca"},"publisher":{"@type":"Organization","name":"","logo":{"@type":"ImageObject","url":"","width":0,"height":0}},"description":"By MARK H. STOWERS Though many have been bypassed others have withered to a small portion of their former stature, Delta small towns once thrived and were stand-alone entities with their own economies and idiosyncrasies. Farming communities that thrived with cotton have shifted to other crops to sustain themselves and the rich Delta land. Drew [&hellip;]","commentCount":"0","image":{"@type":"ImageObject","url":"http:\/\/deltabusinessjournal.com\/wp-content\/uploads\/2018\/01\/Small-Town-Living-1024x691.jpeg","width":1024,"height":691}}]</script><!-- /SCHEMA END -->		<!-- wp_footer -->
		

<a href="https://heapanalytics.com/?utm_source=badge" rel="nofollow"><img style="width:108px;height:41px" src="//heapanalytics.com/img/badge.png" alt="Heap | Mobile and Web Analytics" /></a><script type='text/javascript'>
/* <![CDATA[ */
var themify_vars = {"version":"3.3.9","url":"http:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify","map_key":null,"includesURL":"http:\/\/deltabusinessjournal.com\/wp-includes\/","isCached":null,"minify":{"css":{"themify-icons":1,"themify.framework":1,"lightbox":1,"themify-builder-style":1},"js":{"backstretch.themify-version":1,"bigvideo":1,"themify.dropdown":1,"themify-tiles":1,"themify.mega-menu":1,"themify.builder.script":1,"themify.scroll-highlight":1,"themify-youtube-bg":1,"themify.parallaxit":1}}};
var tbLocalScript = {"isAnimationActive":"1","isParallaxActive":"1","isParallaxScrollActive":"1","animationInviewSelectors":[".module.wow",".module_row.wow",".builder-posts-wrap > .post.wow"],"backgroundSlider":{"autoplay":5000,"speed":2000},"animationOffset":"100","videoPoster":"http:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify\/themify-builder\/img\/blank.png","backgroundVideoLoop":"yes","builder_url":"http:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify\/themify-builder","framework_url":"http:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify","version":"3.3.9","fullwidth_support":"1","fullwidth_container":"body","loadScrollHighlight":"1","addons":[],"breakpoints":{"tablet_landscape":[769,"1024"],"tablet":[681,"768"],"mobile":"480"}};
var themifyScript = {"lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"lightboxContext":"body"};
var tbScrollHighlight = {"fixedHeaderSelector":"#headerwrap.fixed-header","speed":"900","navigation":"#main-nav","scrollOffset":"-5"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='http://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/js/main.min.js?ver=3.3.9'></script>
<script type='text/javascript' src='http://deltabusinessjournal.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' defer="defer" src='http://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/js/themify.sidemenu.min.js?ver=1.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themifyScript = {"themeURI":"http:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra","lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"lightboxContext":"#pagewrap","fixedHeader":"fixed-header","sticky_header":"","ajax_nonce":"20a7a8a088","ajax_url":"http:\/\/deltabusinessjournal.com\/wp-admin\/admin-ajax.php","smallScreen":"760","resizeRefresh":"250","parallaxHeader":"1","loadingImg":"http:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/images\/loading.gif","maxPages":"0","currentPage":"1","autoInfinite":"auto","infiniteURL":"0","scrollToNewOnLoad":"scroll","resetFilterOnLoad":"reset","fullPageScroll":"","shop_masonry":"no","scrollHighlight":{"scroll":"internal"},"tiledata":{"grids":{"post":{"1":["AAAA"],"2":["BBCC","BBCC"],"3":["DD.."],"4":[".EEF",".EEF"],"5":["DD..","BBCC","BBCC"],"6":[".EEF",".EEF","BBCC","BBCC"],"7":[".EEF",".EEF","DD.."],"8":[".EEF",".EEF","DD..","AAAA"],"9":[".EEF",".EEF","DD..","BBCC","BBCC"],"10":[".EEF",".EEF","DD..","MMNN","MMPP"],"11":[".EEF",".EEF","DD..","MMNN","MMPP","AAAA"],"12":[".EEF",".EEF","DD..","MMNN","MMPP","BBCC","BBCC"],"13":[".EEF",".EEF","DD..","MMNN","MMPP","LSRR","LSRR"]},"mobile":["AA",".."]},"default_grid":"post","small_screen_grid":"mobile","breakpoint":800,"padding":5,"full_width":false,"animate_init":false,"animate_resize":true,"animate_template":false}};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='http://deltabusinessjournal.com/wp-content/themes/themify-ultra/js/themify.script.min.js?ver=1.9.1'></script>
<script type='text/javascript' src='http://deltabusinessjournal.com/wp-includes/js/comment-reply.min.js?ver=4.9.1'></script>
<script type='text/javascript' src='http://deltabusinessjournal.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>
	</body>
</html>