
<!DOCTYPE html>
<html lang="en-US">

<head>
		<meta charset="UTF-8" />
	<!-- wp_head -->
	
	<!-- This site is optimized with the Yoast SEO plugin v15.9.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Pete Johnson - Delta Business Journal</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://deltabusinessjournal.com/pete-johnson-3/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Pete Johnson - Delta Business Journal" />
	<meta property="og:description" content="A Life Of Service, Faith&#8230;And Quiet Resolve By Jack Criss&nbsp; •&nbsp; Photography by Austin Britt Pete Johnson cuts a significant historical figure in Mississippi history. He also hails from a family that has made an indelible mark on this state. And, yet his lifetime filled with accomplishments and achievement is overshadowed by his humble faith, [&hellip;]" />
	<meta property="og:url" content="https://deltabusinessjournal.com/pete-johnson-3/" />
	<meta property="og:site_name" content="Delta Business Journal" />
	<meta property="article:publisher" content="https://www.facebook.com/DeltaBusinessJournal" />
	<meta property="article:published_time" content="2021-05-07T11:48:54+00:00" />
	<meta property="article:modified_time" content="2021-05-07T11:48:56+00:00" />
	<meta property="og:image" content="https://deltabusinessjournal.com/wp-content/uploads/2021/05/DBJ-May-2021-Cover.jpg" />
	<meta property="og:image:width" content="448" />
	<meta property="og:image:height" content="600" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="deltabus-ca">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="13 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://deltabusinessjournal.com/#website","url":"https://deltabusinessjournal.com/","name":"Delta Business Journal","description":"Business news for the Mississippi Delta","potentialAction":[{"@type":"SearchAction","target":"https://deltabusinessjournal.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://deltabusinessjournal.com/pete-johnson-3/#primaryimage","inLanguage":"en-US","url":"https://deltabusinessjournal.com/wp-content/uploads/2021/05/DBJ-May-2021-Cover.jpg","width":448,"height":600},{"@type":"WebPage","@id":"https://deltabusinessjournal.com/pete-johnson-3/#webpage","url":"https://deltabusinessjournal.com/pete-johnson-3/","name":"Pete Johnson - Delta Business Journal","isPartOf":{"@id":"https://deltabusinessjournal.com/#website"},"primaryImageOfPage":{"@id":"https://deltabusinessjournal.com/pete-johnson-3/#primaryimage"},"datePublished":"2021-05-07T11:48:54+00:00","dateModified":"2021-05-07T11:48:56+00:00","author":{"@id":"https://deltabusinessjournal.com/#/schema/person/de9d7d40ab50c0dcae34d6e7aca0e09d"},"breadcrumb":{"@id":"https://deltabusinessjournal.com/pete-johnson-3/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://deltabusinessjournal.com/pete-johnson-3/"]}]},{"@type":"BreadcrumbList","@id":"https://deltabusinessjournal.com/pete-johnson-3/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://deltabusinessjournal.com/","url":"https://deltabusinessjournal.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://deltabusinessjournal.com/pete-johnson-3/","url":"https://deltabusinessjournal.com/pete-johnson-3/","name":"Pete Johnson"}}]},{"@type":"Person","@id":"https://deltabusinessjournal.com/#/schema/person/de9d7d40ab50c0dcae34d6e7aca0e09d","name":"deltabus-ca"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Delta Business Journal &raquo; Feed" href="https://deltabusinessjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Delta Business Journal &raquo; Comments Feed" href="https://deltabusinessjournal.com/comments/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v6.7.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-96540291-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var em_version = '6.7.0';
				var em_track_user = true;
				var em_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-96540291-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( em_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dNDMyYj' : true,
						                    });
					__gtagTracker( 'config', 'UA-96540291-1', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by ExactMetrics -->
				<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-96540291-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-96540291-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-96540291-1', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='themify-common-css'  href='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/css/themify.common.min.css?ver=5.5.5' type='text/css' media='all' />
<meta name="themify-framework-css" content="themify-framework-css" id="themify-framework-css">
<meta name="builder-styles-css" content="" id="builder-styles-css">
<link rel='stylesheet' id='wp-block-library-css'  href='https://deltabusinessjournal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.5' type='text/css' media='all' />
<link rel='stylesheet' id='theme-style-css'  href='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/style.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='themify-media-queries-css'  href='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/media-queries.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='themify-customize-css'  href='https://deltabusinessjournal.com/wp-content/uploads/themify-customizer.css?ver=17.06.15.12.55.01' type='text/css' media='all' />
<link rel='stylesheet' id='themify-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400italic%2C600italic%2C700italic%2C400%2C300%2C600%2C700&#038;subset=latin&#038;ver=5.5.5&#038;display=swap' type='text/css' media='all' />
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/deltabusinessjournal.com","hash_tracking":"false","ua":"UA-96540291-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=6.7.0' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/deltabusinessjournal.com","hash_tracking":"false","ua":"UA-96540291-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.17.0' id='monsterinsights-frontend-script-js'></script>
<link rel="https://api.w.org/" href="https://deltabusinessjournal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://deltabusinessjournal.com/wp-json/wp/v2/posts/2657" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://deltabusinessjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://deltabusinessjournal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.5" />
<link rel='shortlink' href='https://deltabusinessjournal.com/?p=2657' />
<link rel="alternate" type="application/json+oembed" href="https://deltabusinessjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdeltabusinessjournal.com%2Fpete-johnson-3%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://deltabusinessjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdeltabusinessjournal.com%2Fpete-johnson-3%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":2657,"post_name":"pete-johnson-3","post_title":"Pete Johnson","post_type":"post","post_author":"5","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":4,"name":"Cover Stories","slug":"cover-stories","term_group":0,"term_taxonomy_id":4,"taxonomy":"category","description":"","parent":0,"count":54,"filter":"raw","cat_ID":4,"category_count":54,"category_description":"","cat_name":"Cover Stories","category_nicename":"cover-stories","category_parent":0}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"deltabus-ca","ID":5};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="173014" async></script>



<script type="text/javascript">
    window.heap=window.heap||[],heap.load=function(e,t){window.heap.appid=e,window.heap.config=t=t||{};var r=t.forceSSL||"https:"===document.location.protocol,a=document.createElement("script");a.type="text/javascript",a.async=!0,a.src=(r?"https:":"http:")+"//cdn.heapanalytics.com/js/heap-"+e+".js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(a,n);for(var o=function(e){return function(){heap.push([e].concat(Array.prototype.slice.call(arguments,0)))}},p=["addEventProperties","addUserProperties","clearEventProperties","identify","removeEventProperty","setEventProperties","track","unsetEventProperty"],c=0;c<p.length;c++)heap[p[c]]=o(p[c])};
      heap.load("255883404");
</script>
<meta name="google-site-verification" content="QsDs463dxODSgT8rStvSwfYtv5EFerXLC_iInYcMEFA" />	<script type="text/javascript" defer>
		var tf_mobile_menu_trigger_point = 768;
	</script>
<meta name="viewport" content="width=device-width, initial-scale=1">

	<style>
	@-webkit-keyframes themifyAnimatedBG {
		0% { background-color: #33baab; }
100% { background-color: #e33b9e; }
50% { background-color: #4961d7; }
33.333333333333% { background-color: #2ea85c; }
25% { background-color: #2bb8ed; }
20% { background-color: #dd5135; }

	}
	@keyframes themifyAnimatedBG {
		0% { background-color: #33baab; }
100% { background-color: #e33b9e; }
50% { background-color: #4961d7; }
33.333333333333% { background-color: #2ea85c; }
25% { background-color: #2bb8ed; }
20% { background-color: #dd5135; }

	}
	.themify_builder_row.animated-bg {
		-webkit-animation: themifyAnimatedBG 30000ms infinite alternate;
		animation: themifyAnimatedBG 30000ms infinite alternate;
	}
	</style>
	
</head>

<body data-rsssl=1 class="post-template-default single single-post postid-2657 single-format-standard themify-fw-3-3-9 themify-ultra-1-9-1 skin-default not-ie default_width sidebar1 no-home no-touch builder-parallax-scrolling-active header-block fixed-header shrinking-logo footer-block  tagline-off rss-off search-off single-classic-layout tile_enable filter-hover-none filter-featured-only masonry-enabled">

<script type="text/javascript">
	function themifyMobileMenuTrigger(e) {
		if( document.body.clientWidth <= tf_mobile_menu_trigger_point ) {
			document.body.classList.add( 'mobile_menu_active' );
		} else {
			document.body.classList.remove( 'mobile_menu_active' );
		}
	}
	themifyMobileMenuTrigger();
	document.addEventListener( 'DOMContentLoaded', function () {
		jQuery( window ).on('tfsmartresize.tf_mobile_menu', themifyMobileMenuTrigger );
	}, false );
</script>

<div id="pagewrap" class="hfeed site">

			<div id="headerwrap"   >
                        			                                                    <div class="header-icons">
                                <a id="menu-icon" href="#mobile-menu"></a>
                            </div>
                        
			<header id="header" class="pagewidth clearfix" itemscope="itemscope" itemtype="https://schema.org/WPHeader">

	            
	            <div class="header-bar">
		            						<div id="site-logo"><a href="https://deltabusinessjournal.com" title="Delta Business Journal"><img src="https://deltabusinessjournal.com/wp-content/uploads/2017/03/Delta-Business-Journal-Logo.png" alt="Delta Business Journal" title="Delta Business Journal" /></a></div>					
									</div>
				<!-- /.header-bar -->

									<div id="mobile-menu" class="sidemenu sidemenu-off">

						<div class="navbar-wrapper clearfix">

															<div class="social-widget">
																												
																	</div>
								<!-- /.social-widget -->
							
							
							<nav id="main-nav-wrap" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
																	<ul id="main-nav" class="main-nav menu-name-primary"><li id='menu-item-155' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home" ><a  href="https://deltabusinessjournal.com/">Home</a> </li>
<li id='menu-item-26' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/about-delta-business-journal/">About DBJ</a> </li>
<li id='menu-item-105' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/subscribe/">Subscribe</a> </li>
<li id='menu-item-24' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/contact-us/">Contact Us</a> </li>
<li id='menu-item-458' class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children has-sub-menu has-sub-menu" ><a >Archives</a> 
<ul class="sub-menu">
<li id='menu-item-470' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/cover-stories/">Cover Stories</a> </li>
<li id='menu-item-469' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/feature-stories/">Features</a> </li>
<li id='menu-item-484' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/from-the-publisher/">From the Publisher</a> </li>
<li id='menu-item-483' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/guest-column/">Guest Columns</a> </li>
<li id='menu-item-467' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/latest-news/">Latest News</a> </li>
<li id='menu-item-492' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/question-and-answer/">Q&#038;A</a> </li>
<li id='menu-item-468' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/viewpoints/">Viewpoints</a> </li>
</ul>
</li>
<li id='menu-item-25' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/media-kit/">Media Kit</a> </li>
<li id='menu-item-126' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/business-brief/">Business Brief</a> </li>
</ul>									<!-- /#main-nav -->
									
																		
															</nav>
							<!-- /#main-nav-wrap -->
							
						</div>

																				<!-- /header-widgets -->
						
						<a id="menu-icon-close" href="#"></a>
					</div>
					<!-- /#mobile-menu -->
				
				
				
				
			</header>
			<!-- /#header -->

	        
		</div>
		<!-- /#headerwrap -->
	
	<div id="body" class="clearfix">

		

	
	<!-- layout-container -->
	<div id="layout" class="pagewidth clearfix">

		
		<!-- content -->
		<div id="content" class="list-post">
			
			
				

<article id="post-2657" class="post clearfix post-2657 type-post status-publish format-standard has-post-thumbnail hentry category-cover-stories has-post-title has-post-date no-post-category has-post-tag no-post-comment no-post-author   cat-4">
	
            <a href="https://deltabusinessjournal.com/pete-johnson-3/" data-post-permalink="yes" style="display: none;"></a>
    
	
	
	
		
			<figure class="post-image  clearfix">

									<a href="https://deltabusinessjournal.com/pete-johnson-3/"><img loading="lazy" src="https://deltabusinessjournal.com/wp-content/uploads/2021/05/DBJ-May-2021-Cover-275x400.jpg" width="275" height="400" class=" wp-post-image wp-image-2650" alt="Layout 1" /></a>
				
			</figure>

		
	
	
	<div class="post-content">
		<div class="post-content-inner">

							<div class="post-date-wrap post-date-inline">
					<time class="post-date entry-date updated" datetime="2021-05-07">
                                                                                            <span class="year">May 7, 2021</span>
                                            					</time>
				</div>
			
							 <h1 class="post-title entry-title"><a href="https://deltabusinessjournal.com/pete-johnson-3/">Pete Johnson</a> </h1>			
							<p class="post-meta entry-meta">
					
					
																
									</p>
				<!-- /post-meta -->
			
			
			<div class="entry-content">

				
					
<p>A Life Of Service, Faith&#8230;And Quiet Resolve</p>



<p>By Jack Criss&nbsp; •&nbsp; Photography by Austin Britt</p>



<p>Pete Johnson cuts a significant historical figure in Mississippi history. He also hails from a family that has made an indelible mark on this state. And, yet his lifetime filled with accomplishments and achievement is overshadowed by his humble faith, his sense of duty and his gratefulness in simply being alive.</p>



<p>“I’ve never been able to sit still,” says Johnson with a laugh when reminded of his impressive life of service at the beginning of this interview. “I don’t just expect things or events to happen—I’ve tried to make things active. That’s how I’ve been since my youth. I played basketball as a young man and I was the smallest player on the school team. But, I out-hustled and out-worked the better players. I wasn’t a great player—but I was a great worker. And on my desk right now is a big letter ‘A’ that was presented to me for my efforts on that team. That attitude has stayed with me throughout my professional life: there’s always been others smarter, stronger, wealthier than I’ve been—but I effectively compete with such people by getting up earlier, staying up later and putting in the work at all costs. That has been the theme of my life. I’ve been knocked down many times, to be sure—but I’ve always gotten up.”</p>



<p>As a man who has—quite literally—faced death up close, Johnson says there’s never been a time in his life when he even felt close to giving up.&nbsp;</p>



<p>“Part of this resiliency is due to divine intervention—there’s no question about it,” he says. “Winning or losing is ultimately not always the relevant outcome of any given situation; it’s remaining faithful to God and giving one’s best in all situations and circumstances. I recall one particularly tough and challenging election I was involved with in the 80s. Towards the end of that gruelling experience I went into Saint Elizabeth’s Catholic Church, got on my knees by myself, and asked, ‘Why, Lord? Why is this happening to me? I got into this race because I knew that you wanted me to do it.’ And, God answered me in a voice as clear as day. He replied, ‘Because I love you.’ My reaction was one of shock at first. But, looking back, I think it goes back to His meaning one must endure, keep one’s faith and not lose it in the face of adversaries. But ultimately, it may not be important to totally understand what God wants us; what is important is that we remain faithful.”</p>



<p>Johnson says that now, when he looks back over the many experiences of his life, he has to shake his head in awe.&nbsp;</p>



<p>“For instance, when I made the party switch from Democrat to Republican, I took a lot of heat from former constituents and friends—almost to the point of hatred,” he says. “But, I just felt I no longer fit in philosophically. I remember Thad Cochran telling me flat out, ‘Pete, they don’t want you.’ And, he was absolutely right. Well, President George H.W. Bush had a ceremony at The White House in the Rose Garden for me and about 19 other politicians who had switched their party allegiance to the GOP. We were in the Oval Office with President Bush and Vice-President Dan Quayle before we went out to be introduced and recognized and I remember then, too, wondering what God had in store for me as I took this new step. But, you know,” adds Johnson, “having come close to death on more than one occasion and facing the precipice of eternity, I now look at all those ceremonies and recognitions, while fulfilling in their own way, as almost afterthoughts. So many things that we think at the time are so significant we realize, in hindsight and after traumatic experiences, are not so significant after all.”</p>



<p>Johnson was born in Alexandria, Louisiana, on May 12, 1948. Both his grandfather, Paul B. Johnson, Sr., and uncle, Paul B. Johnson, Jr., served as Governor of Mississippi. He graduated from Murrah High School in Jackson in 1966 and attended the University of Mississippi, receiving a Bachelor of Business Administration degree in 1971 and is also a graduate of the LSU School of Banking of the South. Johnson obtained his law degree from the former Jackson School of Law, now the Mississippi College Law School, and was admitted to practice law in 1974. .</p>



<p>After receiving his law degree, Johnson joined the Bank of Clarksdale in Clarksdale as Senior Vice-President and Trust Officer. In the years to come, he was recognized as one of Mississippi’s top leaders by the Mississippi Economic Council, served as the President of the Young Bankers Section of the Mississippi Bankers Association, and formed and operated his own financial planning firm in Clarksdale. He was also appointed by Governor Bill Allain as chairman of the Mississippi Marketing Council in 1984.</p>



<figure class="wp-block-gallery columns-3 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><img loading="lazy" width="800" height="546" src="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG_4420-copy.jpg" alt="" data-id="2651" data-full-url="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG_4420-copy.jpg" data-link="https://deltabusinessjournal.com/img_4420-copy/" class="wp-image-2651" srcset="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG_4420-copy.jpg 800w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG_4420-copy-300x205.jpg 300w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG_4420-copy-150x102.jpg 150w" sizes="(max-width: 800px) 100vw, 800px" /></figure></li><li class="blocks-gallery-item"><figure><img loading="lazy" width="756" height="600" src="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4418-copy.jpg" alt="" data-id="2652" data-full-url="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4418-copy.jpg" data-link="https://deltabusinessjournal.com/img-4418-copy/" class="wp-image-2652" srcset="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4418-copy.jpg 756w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4418-copy-300x238.jpg 300w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4418-copy-150x119.jpg 150w" sizes="(max-width: 756px) 100vw, 756px" /></figure></li><li class="blocks-gallery-item"><figure><img loading="lazy" width="761" height="600" src="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4419-copy.jpg" alt="" data-id="2653" data-full-url="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4419-copy.jpg" data-link="https://deltabusinessjournal.com/img-4419-copy/" class="wp-image-2653" srcset="https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4419-copy.jpg 761w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4419-copy-300x237.jpg 300w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/IMG-4419-copy-150x118.jpg 150w" sizes="(max-width: 761px) 100vw, 761px" /></figure></li></ul></figure>



<p>Johnson was subsequently elected Mississippi’s State Auditor in 1987. Upon leaving the Auditor’s office in 1992 (and an unsuccessful run for governor) Johnson was appointed by President George Bush as Mississippi’s State Director of the Farmers’ Home Administration, where he coordinated one of the largest Farm and Rural Development programs in the United States at the time. Johnson practiced law in Clarksdale before being named Federal Co-Chair of the Delta Regional Authority (DRA) by President George W. Bush, serving from 2002-2011 under both the Bush and Obama administrations. Johnson worked across the aisle during his tenure at the Delta Regional Authority while never reneging on his conservative principles. “With return on tax dollar investment, our time at the DRA ranks as one of the most successful government programs recently created and I’m extremely proud of that,” says Johnson.</p>



<p>Hayes Dent of Yazoo City, a political consultant and longtime active member of the state’s Republican Party, served in an executive role with Johnson in Clarksdale at Delta Regional Authority.&nbsp;</p>



<p>“Pete always aimed to serve the public,” recalls Dent. “That may sound quaint today, but that was just Pete’s way. It was all about service—always. He had the genetic, family tradition of service in him, of course, and with Pete it was a genuine desire. At the DRA, Pete was partisan for the Delta—he always kept our organization true to its mission on track and that was to help the Delta region and footprint. I learned from Pete to always keep your eye on the ball.” Forget the fanfare, the dignitaries you met on the job or what have you—it was to focus on the tasks right in front of you and staying true to that task.”</p>



<p>Besides his many and varied business and government experiences, Johnson has been a dedicated community leader, involved in many civic and economic organizations. He has served as the President of the Clarksdale-Coahoma County Chamber of Commerce, Chairman of the Industrial Foundation, Director of the Delta Council’s Community and Industrial Development Board, Trustee of the Northwest Medical Regional Medical Center, Board Member of the Clarksdale Presbyterian Day School, among countless other boards, and in 1987 he was awarded the Goodman, Chaney, Schwerner Award for his steadfast commitment to equal rights and opportunities for everyone. Johnson is also very active in Habitat for Humanity, is a Rotarian, and serves as an elder in the First Presbyterian Church of Clarksdale. Johnson is an instrument-rated private pilot and an avid outdoorsman, enjoying hunting, fishing, and golf.</p>



<p>Johnson is married to the former Margaret Birdsong of Clarksdale and has been for 51 years. They are the parents of two daughters, Mary Margaret of Atlanta, Georgia, and Anne Clark, of Denver, Colorado and have five granddaughters.</p>



<p>It was in 1996 during an outdoor expedition when Johnson experienced an incredible brush with death—one that ended up forever altering his world and outlook on life.&nbsp;</p>



<p>“Every New Year’s Eve, my friend John Duff and his two sons, Matthew and Andrew, pack up their hunting gear and load horses, dogs and provisions for a two-week expedition on Big Island, the largest and last extensive hardwood stand of timber in the Mississippi River,” says Johnson. “The morning of January 2, I awoke in Tupelo with a sore throat.&nbsp; Nothing particularly unusual for the winter season. As a precaution, though, I stopped by a local pharmacy and purchased throat lozenges and other over-the-counter medication to ward off any annoying scratchy throat or common cold that might threaten to spoil out hunt,” says Johnnon. Little did I know that this seemingly innocent sore throat was the subtle prelude to events that would literally have me at death’s door.</p>



<p>“I left my family in Tupelo and, as an added precaution, picked up a 21-foot river boat at John’s farm,” continues Johnson. “We decided it would be a good idea to have another boat, in case an emergency arose .I crossed the river and joined the rest of the hunters on the island late that afternoon. As the evening grew on and the chill of the night began to settle in the hunting camp, my sore throat grew worse and my coughs became deeper and more frequent. The next morning my health had not improved and I was in extreme pain.</p>



<p>“After saddling Lucky, I coughed again but this time the pain riveting through my chest was unbearable,” says Johnson. “I noticed that my temperature had risen and decided that riding this morning was not a good idea.&nbsp; I returned to the cabin where I was staying with John in hopes that my condition would improve. At 2:00 a.m. the following morning my condition had deteriorated. I awoke nauseated and coughing.&nbsp; Then the unthinkable happened; I began throwing up volumes of blood and I called out to John. He came barreling out of his bed to find the entire floor covered with my blood. I said, ‘John, listen to me carefully. In 1987 I was diagnosed with Hepatitis C and it destroys your liver. In the end stages of your liver functioning, the veins in your esophagus may erupt. If you don’t get me to a hospital I will bleed to death in 45 minutes.’”</p>



<p>Duff dialed 911 and was connected with the dispatcher in the Bolivar County, Mississippi Sheriff’s office.&nbsp;</p>



<p>“Without a moment to spare, John put boots on my feet and wrapped me in warm blankets,” Johnson goes to recount. “He then awoke the rest of the camp alerting them to the danger I was in and began giving orders like a field commander in battle.&nbsp; No one questioned his judgment or his commands.&nbsp; He decided to load me in a truck and drive me as close to the edge of the river as possible.&nbsp; The bank was slippery from the winter rains and negotiating the steep slope would be difficult at best. One misstep could spell disaster. As we began to cross the river, I could feel my stomach filling with blood and for the first time realized how close to death I really was.&nbsp; I began to pray.&nbsp; I prayed for courage, I prayed for deliverance, I prayed for forgiveness.&nbsp; And, then I came to the point in my prayer where I routinely proclaim, ‘Let not my will but Thy will be done.’” His friend John never left his side as Johnson was assisted up the boat ramp and driven to the nearest hospital 30 miles away.”&nbsp;</p>



<figure class="wp-block-gallery columns-3 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><img loading="lazy" width="800" height="533" src="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-2-copy.jpg" alt="" data-id="2654" data-full-url="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-2-copy.jpg" data-link="https://deltabusinessjournal.com/pete_-2-copy/" class="wp-image-2654" srcset="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-2-copy.jpg 800w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-2-copy-300x200.jpg 300w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-2-copy-150x100.jpg 150w" sizes="(max-width: 800px) 100vw, 800px" /></figure></li><li class="blocks-gallery-item"><figure><img loading="lazy" width="400" height="600" src="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-9-copy.jpg" alt="" data-id="2655" data-full-url="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-9-copy.jpg" data-link="https://deltabusinessjournal.com/pete_-9-copy/" class="wp-image-2655" srcset="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-9-copy.jpg 400w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-9-copy-200x300.jpg 200w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-9-copy-100x150.jpg 100w" sizes="(max-width: 400px) 100vw, 400px" /></figure></li><li class="blocks-gallery-item"><figure><img loading="lazy" width="400" height="600" src="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-18-copy.jpg" alt="" data-id="2656" data-full-url="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-18-copy.jpg" data-link="https://deltabusinessjournal.com/pete_-18-copy/" class="wp-image-2656" srcset="https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-18-copy.jpg 400w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-18-copy-200x300.jpg 200w, https://deltabusinessjournal.com/wp-content/uploads/2021/05/Pete_-18-copy-100x150.jpg 100w" sizes="(max-width: 400px) 100vw, 400px" /></figure></li></ul></figure>



<p>Johnson’s blood pressure dropped to sixty over forty and he was losing ground fast.&nbsp; Shortly after arriving at the hospital, he began to spit up even more blood.&nbsp;</p>



<p>“After six hours of intense but unsuccessful efforts, a call was made to Greenwood,&nbsp; some forty-five miles away, because I wouldn’t have survived a trip to Jackson as I was still rapidly losing blood. There was a new doctor there who could perform the life-saving procedure.”</p>



<p>In the late 1960s, Johnson had contracted Hepatitis C while working as an ambulance driver. &nbsp;</p>



<p>“Back then no one wore protective gloves and I became infected while extricating a traffic victim who was trapped in her car as a result of a head-on collision, says Johnson.&nbsp; “Now as a patient in an ambulance myself, my mind flashed back to that event. When we arrived in Greenwood, the procedure and its potential complications were explained. Hours later I awoke with the bleeding stopped and another chance at life,” says Johnson.</p>



<p>A few years before this experience,&nbsp; in 1992, Baylor University Medical Center in Dallas had accepted Johnson as a candidate for a liver transplant.&nbsp;</p>



<p>“So, when I returned home from Greenwood and was strong enough to make another trip to Dallas, I went out for an additional evaluation. After several days of testing, it was obvious,” he says. “No question about it, I had only a short time to live. Within three weeks, we received a call at 4:30 one morning from Baylor telling me that they had a donor organ and wanted to start the surgery at Noon that day,” says Johnson.</p>



<p>Their chartered airplane arrived at Love Field in Dallas at 11:15 a.m and Johnson was at the hospital by 11:30 and was taken to the 14th floor where they were met by two nurses, a surgeon and the hospital chaplain.</p>



<p>“After completing the formalities of signing releases and other documents, my wife, our two daughters and I held hands and we prayed,” recalls Johnson. “I kissed them goodbye as they rolled me away. The operation was a complete success. But, hardly a moment goes by that I don’t think of that trip to Big Island and the men who saved my life.” &nbsp;</p>



<p>Johnson says the recovery from these experiences was long and often tortuous. But, he prevailed and moved forward—he had more things in life to accomplish after that that fateful night in 1996.</p>



<p>These days Johnson serves as a Managing Director of Providence Management, LLC based in Oxford, MS. He was able to fly again, after many years of being grounded due to the side effects of a hepatitis medication he was taking which the FAA would not approve use of for pilots. Johnson got off of the medication and resumed his passion up until recently. He is also currently involved in other investments and businesses around the state and he and his wife own a second home outside of Charleston, South Carolina, where they divide their time between Clarksdale and Charleston.</p>



<p>Johnson also alludes to future possible work here in Mississippi.&nbsp;</p>



<p>“I’m certainly not retiring anytime soon and there are some positions that are currently being considered,” he says. “As long as I’m able to serve, I’ll certainly do so.”</p>



<p>Was there a crowning achievement in his multifaceted and far-reaching career? “No,” Johnson answers emphatically. “Again, what has been most important in my life is the fact that I have remained faithful and never given up on whatever I wanted to accomplish.” &nbsp;</p>
<div id="themify_builder_content-2657" data-postid="2657" class="themify_builder_content themify_builder_content-2657 themify_builder">

    </div>
<!-- /themify_builder_content -->
				
			</div><!-- /.entry-content -->

			
		</div>
		<!-- /.post-content-inner -->
	</div>
	<!-- /.post-content -->
	
</article>
<!-- /.post -->

			
			
			
			
			
			
					</div>
		<!-- /content -->

		
		    
    <aside id="sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSidebar">

        
	<div id="search-3" class="widget widget_search"><h4 class="widgettitle">Site Search</h4><form method="get" id="searchform" action="https://deltabusinessjournal.com/">

	<i class="icon-search"></i>

	<input type="text" name="s" id="s" title="Search" value="" />

</form></div><div id="themify-social-links-2" class="widget themify-social-links"><h4 class="widgettitle">Connect On Facebook</h4><ul class="social-links horizontal">
							<li class="social-link-item facebook font-icon icon-medium">
								<a href="https://www.facebook.com/DeltaBusinessJournal/" target="_blank"><i class="fa fa-facebook-square" ></i>  </a>
							</li>
							<!-- /themify-link-item --></ul></div><div id="nav_menu-2" class="widget widget_nav_menu"><h4 class="widgettitle">Quick Links</h4><div class="menu-sidebar-1-container"><ul id="menu-sidebar-1" class="menu"><li id="menu-item-474" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-474"><a href="https://deltabusinessjournal.com/cover-stories/">Cover Stories</a></li>
<li id="menu-item-473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-473"><a href="https://deltabusinessjournal.com/feature-stories/">Features</a></li>
<li id="menu-item-472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-472"><a href="https://deltabusinessjournal.com/viewpoints/">Viewpoints</a></li>
<li id="menu-item-471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471"><a href="https://deltabusinessjournal.com/latest-news/">Latest News</a></li>
</ul></div></div><div id="mc_mm_widget-5" class="widget widget_mc_mm_widget"><h4 class="widgettitle">Get the Brief</h4><div class='mailmunch-wordpress-widget mailmunch-wordpress-widget-224483' style='display: none !important;'></div></div>
        
    </aside>
    <!-- /#sidebar -->

    
	</div>
	<!-- /layout-container -->



        			</div>
			<!-- /body -->

							<div id="footerwrap"   >

					
					<footer id="footer" class="pagewidth clearfix" itemscope="itemscope" itemtype="https://schema.org/WPFooter">

						
													                            <div class="back-top clearfix ">
                                <div class="arrow-up">
                                    <a href="#header"></a>
                                </div>
                            </div>
                        
						<div class="main-col first clearfix">
							<div class="footer-left-wrap first">
																	<div class="footer-logo-wrapper clearfix">
										<div id="footer-logo"><a href="https://deltabusinessjournal.com" title="Delta Business Journal"><span>Delta Business Journal</span></a></div>										<!-- /footer-logo -->
									</div>
															
															</div>
							
							<div class="footer-right-wrap">

																	<div class="footer-nav-wrap">
																			</div>
									<!-- /.footer-nav-wrap -->
																									<div class="footer-text clearfix">
										<div class="footer-text-inner">
																							<div class="one">Copyright 2020 Delta Business Journal</div>																																	</div>
									</div>
									<!-- /.footer-text -->
															</div>
						</div>

																					<div class="section-col clearfix">
									<div class="footer-widgets-wrap">
																				<!-- /footer-widgets -->
									</div>
								</div>
													
						
					</footer>
					<!-- /#footer -->

					
				</div>
				<!-- /#footerwrap -->
			
		</div>
		<!-- /#pagewrap -->

		
		<!-- SCHEMA BEGIN --><script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"BlogPosting","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/deltabusinessjournal.com\/pete-johnson-3\/"},"headline":"Pete Johnson","datePublished":"2021-05-07T06:48:54-05:00","dateModified":"2021-05-07T06:48:54-05:00","author":{"@type":"Person","name":"deltabus-ca"},"publisher":{"@type":"Organization","name":"","logo":{"@type":"ImageObject","url":"","width":0,"height":0}},"description":"A Life Of Service, Faith&#8230;And Quiet Resolve By Jack Criss&nbsp; \u2022&nbsp; Photography by Austin Britt Pete Johnson cuts a significant historical figure in Mississippi history. He also hails from a family that has made an indelible mark on this state. And, yet his lifetime filled with accomplishments and achievement is overshadowed by his humble faith, [&hellip;]","commentCount":"0","image":{"@type":"ImageObject","url":"https:\/\/deltabusinessjournal.com\/wp-content\/uploads\/2021\/05\/DBJ-May-2021-Cover.jpg","width":448,"height":600}}]</script><!-- /SCHEMA END -->		<!-- wp_footer -->
		

<a href="https://heapanalytics.com/?utm_source=badge" rel="nofollow"><img style="width:108px;height:41px" src="//heapanalytics.com/img/badge.png" alt="Heap | Mobile and Web Analytics" /></a><script type='text/javascript' id='themify-main-script-js-extra'>
/* <![CDATA[ */
var themify_vars = {"version":"3.3.9","url":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify","map_key":null,"includesURL":"https:\/\/deltabusinessjournal.com\/wp-includes\/","isCached":null,"minify":{"css":{"themify-icons":1,"themify.framework":1,"lightbox":1,"themify-builder-style":1},"js":{"backstretch.themify-version":1,"bigvideo":1,"themify.dropdown":1,"themify-tiles":1,"themify.mega-menu":1,"themify.builder.script":1,"themify.scroll-highlight":1,"themify-youtube-bg":1,"themify.parallaxit":1}}};
var tbLocalScript = {"isAnimationActive":"1","isParallaxActive":"1","isParallaxScrollActive":"1","animationInviewSelectors":[".module.wow",".module_row.wow",".builder-posts-wrap > .post.wow"],"backgroundSlider":{"autoplay":5000,"speed":2000},"animationOffset":"100","videoPoster":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify\/themify-builder\/img\/blank.png","backgroundVideoLoop":"yes","builder_url":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify\/themify-builder","framework_url":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify","version":"3.3.9","fullwidth_support":"1","fullwidth_container":"body","loadScrollHighlight":"1","addons":[],"breakpoints":{"tablet_landscape":[769,"1024"],"tablet":[681,"768"],"mobile":"480"}};
var themifyScript = {"lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"lightboxContext":"body"};
var tbScrollHighlight = {"fixedHeaderSelector":"#headerwrap.fixed-header","speed":"900","navigation":"#main-nav","scrollOffset":"-5"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/js/main.min.js?ver=3.3.9' id='themify-main-script-js'></script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' defer="defer" src='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/js/themify.sidemenu.min.js?ver=1.9.1' id='slide-nav-js'></script>
<script type='text/javascript' id='theme-script-js-extra'>
/* <![CDATA[ */
var themifyScript = {"themeURI":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra","lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"lightboxContext":"#pagewrap","fixedHeader":"fixed-header","sticky_header":"","ajax_nonce":"1b17f04ff2","ajax_url":"https:\/\/deltabusinessjournal.com\/wp-admin\/admin-ajax.php","smallScreen":"760","resizeRefresh":"250","parallaxHeader":"1","loadingImg":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/images\/loading.gif","maxPages":"0","currentPage":"1","autoInfinite":"auto","infiniteURL":"0","scrollToNewOnLoad":"scroll","resetFilterOnLoad":"reset","fullPageScroll":"","shop_masonry":"no","scrollHighlight":{"scroll":"internal"},"tiledata":{"grids":{"post":{"1":["AAAA"],"2":["BBCC","BBCC"],"3":["DD.."],"4":[".EEF",".EEF"],"5":["DD..","BBCC","BBCC"],"6":[".EEF",".EEF","BBCC","BBCC"],"7":[".EEF",".EEF","DD.."],"8":[".EEF",".EEF","DD..","AAAA"],"9":[".EEF",".EEF","DD..","BBCC","BBCC"],"10":[".EEF",".EEF","DD..","MMNN","MMPP"],"11":[".EEF",".EEF","DD..","MMNN","MMPP","AAAA"],"12":[".EEF",".EEF","DD..","MMNN","MMPP","BBCC","BBCC"],"13":[".EEF",".EEF","DD..","MMNN","MMPP","LSRR","LSRR"]},"mobile":["AA",".."]},"default_grid":"post","small_screen_grid":"mobile","breakpoint":800,"padding":5,"full_width":false,"animate_init":false,"animate_resize":true,"animate_template":false}};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/js/themify.script.min.js?ver=1.9.1' id='theme-script-js'></script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/comment-reply.min.js?ver=5.5.5' id='comment-reply-js'></script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/wp-embed.min.js?ver=5.5.5' id='wp-embed-js'></script>
	</body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1621209693 -->