
<!DOCTYPE html>
<html lang="en-US">

<head>
		<meta charset="UTF-8" />
	<!-- wp_head -->
	<title>How I Made It… Professionals Discuss How They Got Where They Are Today - Delta Business Journal</title>

<!-- This site is optimized with the Yoast SEO plugin v11.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How I Made It… Professionals Discuss How They Got Where They Are Today - Delta Business Journal" />
<meta property="og:description" content="By Angela Rogalski What defines “making it” professionally? Is it when you’re at the top of your field of expertise and feel that sense of personal and professional satisfaction? Is it going that extra mile in your career and your peers and superiors recognize your endeavors? Or is a little of both and a lot &hellip;" />
<meta property="og:url" content="https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/" />
<meta property="og:site_name" content="Delta Business Journal" />
<meta property="article:publisher" content="https://www.facebook.com/DeltaBusinessJournal" />
<meta property="article:section" content="Special Sections" />
<meta property="article:published_time" content="2019-06-28T12:40:06+00:00" />
<meta property="og:image" content="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons.jpg" />
<meta property="og:image:secure_url" content="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="By Angela Rogalski What defines “making it” professionally? Is it when you’re at the top of your field of expertise and feel that sense of personal and professional satisfaction? Is it going that extra mile in your career and your peers and superiors recognize your endeavors? Or is a little of both and a lot [&hellip;]" />
<meta name="twitter:title" content="How I Made It… Professionals Discuss How They Got Where They Are Today - Delta Business Journal" />
<meta name="twitter:image" content="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://deltabusinessjournal.com/#organization","name":"","url":"https://deltabusinessjournal.com/","sameAs":["https://www.facebook.com/DeltaBusinessJournal"]},{"@type":"WebSite","@id":"https://deltabusinessjournal.com/#website","url":"https://deltabusinessjournal.com/","name":"Delta Business Journal","publisher":{"@id":"https://deltabusinessjournal.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://deltabusinessjournal.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/#primaryimage","url":"https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons.jpg","width":640,"height":800},{"@type":"WebPage","@id":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/#webpage","url":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/","inLanguage":"en-US","name":"How I Made It\u2026 Professionals Discuss How They Got Where They Are Today - Delta Business Journal","isPartOf":{"@id":"https://deltabusinessjournal.com/#website"},"primaryImageOfPage":{"@id":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/#primaryimage"},"datePublished":"2019-06-28T12:40:06+00:00","dateModified":"2019-06-28T12:40:06+00:00"},{"@type":"Article","@id":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/#article","isPartOf":{"@id":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/#webpage"},"author":{"@id":"https://deltabusinessjournal.com/author/deltabus-ca/#author"},"headline":"How I Made It\u2026  Professionals Discuss How They Got Where They Are Today","datePublished":"2019-06-28T12:40:06+00:00","dateModified":"2019-06-28T12:40:06+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/#webpage"},"publisher":{"@id":"https://deltabusinessjournal.com/#organization"},"image":{"@id":"https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/#primaryimage"},"articleSection":"Special Sections"},{"@type":["Person"],"@id":"https://deltabusinessjournal.com/author/deltabus-ca/#author","name":"deltabus-ca","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Delta Business Journal &raquo; Feed" href="https://deltabusinessjournal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Delta Business Journal &raquo; Comments Feed" href="https://deltabusinessjournal.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/deltabusinessjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='themify-common-css'  href='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/css/themify.common.min.css?ver=4.9.5' type='text/css' media='all' />
<meta name="themify-framework-css" content="themify-framework-css" id="themify-framework-css">
<meta name="builder-styles-css" content="" id="builder-styles-css">
<link rel='stylesheet' id='theme-style-css'  href='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/style.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='themify-media-queries-css'  href='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/media-queries.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='themify-customize-css'  href='https://deltabusinessjournal.com/wp-content/uploads/themify-customizer.css?ver=17.06.15.12.55.01' type='text/css' media='all' />
<link rel='stylesheet' id='themify-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400italic%2C600italic%2C700italic%2C400%2C300%2C600%2C700&#038;subset=latin&#038;ver=4.9.5' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://deltabusinessjournal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://deltabusinessjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://deltabusinessjournal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.5" />
<link rel='shortlink' href='https://deltabusinessjournal.com/?p=1484' />
<link rel="alternate" type="application/json+oembed" href="https://deltabusinessjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdeltabusinessjournal.com%2Fhow-i-made-it-professionals-discuss-how-they-got-where-they-are-today%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://deltabusinessjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdeltabusinessjournal.com%2Fhow-i-made-it-professionals-discuss-how-they-got-where-they-are-today%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":1484,"post_name":"how-i-made-it-professionals-discuss-how-they-got-where-they-are-today","post_title":"How I Made It\u2026  Professionals Discuss How They Got Where They Are Today","post_type":"post","post_author":"5","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":34,"name":"Special Sections","slug":"special-sections","term_group":0,"term_taxonomy_id":34,"taxonomy":"category","description":"","parent":0,"count":43,"filter":"raw","cat_ID":34,"category_count":43,"category_description":"","cat_name":"Special Sections","category_nicename":"special-sections","category_parent":0}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"deltabus-ca","ID":5};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="173014" async></script>



<script type="text/javascript">
    window.heap=window.heap||[],heap.load=function(e,t){window.heap.appid=e,window.heap.config=t=t||{};var r=t.forceSSL||"https:"===document.location.protocol,a=document.createElement("script");a.type="text/javascript",a.async=!0,a.src=(r?"https:":"http:")+"//cdn.heapanalytics.com/js/heap-"+e+".js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(a,n);for(var o=function(e){return function(){heap.push([e].concat(Array.prototype.slice.call(arguments,0)))}},p=["addEventProperties","addUserProperties","clearEventProperties","identify","removeEventProperty","setEventProperties","track","unsetEventProperty"],c=0;c<p.length;c++)heap[p[c]]=o(p[c])};
      heap.load("255883404");
</script>
<meta name="google-site-verification" content="QsDs463dxODSgT8rStvSwfYtv5EFerXLC_iInYcMEFA" />	<script type="text/javascript" defer>
		var tf_mobile_menu_trigger_point = 768;
	</script>
<meta name="viewport" content="width=device-width, initial-scale=1">

	<style>
	@-webkit-keyframes themifyAnimatedBG {
		0% { background-color: #33baab; }
100% { background-color: #e33b9e; }
50% { background-color: #4961d7; }
33.333333333333% { background-color: #2ea85c; }
25% { background-color: #2bb8ed; }
20% { background-color: #dd5135; }

	}
	@keyframes themifyAnimatedBG {
		0% { background-color: #33baab; }
100% { background-color: #e33b9e; }
50% { background-color: #4961d7; }
33.333333333333% { background-color: #2ea85c; }
25% { background-color: #2bb8ed; }
20% { background-color: #dd5135; }

	}
	.themify_builder_row.animated-bg {
		-webkit-animation: themifyAnimatedBG 30000ms infinite alternate;
		animation: themifyAnimatedBG 30000ms infinite alternate;
	}
	</style>
	
<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-96540291-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->

</head>

<body data-rsssl=1 class="post-template-default single single-post postid-1484 single-format-standard themify-fw-3-3-9 themify-ultra-1-9-1 skin-default not-ie default_width sidebar1 no-home no-touch builder-parallax-scrolling-active header-block fixed-header shrinking-logo footer-block  tagline-off rss-off search-off single-classic-layout tile_enable filter-hover-none filter-featured-only masonry-enabled">

<script type="text/javascript">
	function themifyMobileMenuTrigger(e) {
		if( document.body.clientWidth <= tf_mobile_menu_trigger_point ) {
			document.body.classList.add( 'mobile_menu_active' );
		} else {
			document.body.classList.remove( 'mobile_menu_active' );
		}
	}
	themifyMobileMenuTrigger();
	document.addEventListener( 'DOMContentLoaded', function () {
		jQuery( window ).on('tfsmartresize.tf_mobile_menu', themifyMobileMenuTrigger );
	}, false );
</script>

<div id="pagewrap" class="hfeed site">

			<div id="headerwrap"   >
                        			                                                    <div class="header-icons">
                                <a id="menu-icon" href="#mobile-menu"></a>
                            </div>
                        
			<header id="header" class="pagewidth clearfix" itemscope="itemscope" itemtype="https://schema.org/WPHeader">

	            
	            <div class="header-bar">
		            						<div id="site-logo"><a href="https://deltabusinessjournal.com" title="Delta Business Journal"><img src="https://deltabusinessjournal.com/wp-content/uploads/2017/03/Delta-Business-Journal-Logo.png" alt="Delta Business Journal" title="Delta Business Journal" /></a></div>					
									</div>
				<!-- /.header-bar -->

									<div id="mobile-menu" class="sidemenu sidemenu-off">

						<div class="navbar-wrapper clearfix">

															<div class="social-widget">
																												
																	</div>
								<!-- /.social-widget -->
							
							
							<nav id="main-nav-wrap" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
																	<ul id="main-nav" class="main-nav menu-name-primary"><li id='menu-item-155' class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home" ><a  href="https://deltabusinessjournal.com/">Home</a> </li>
<li id='menu-item-26' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/about-delta-business-journal/">About DBJ</a> </li>
<li id='menu-item-105' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/subscribe/">Subscribe</a> </li>
<li id='menu-item-24' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/contact-us/">Contact Us</a> </li>
<li id='menu-item-458' class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children has-sub-menu has-sub-menu" ><a >Archives</a> 
<ul class="sub-menu">
<li id='menu-item-470' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/cover-stories/">Cover Stories</a> </li>
<li id='menu-item-469' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/feature-stories/">Features</a> </li>
<li id='menu-item-484' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/from-the-publisher/">From the Publisher</a> </li>
<li id='menu-item-483' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/guest-column/">Guest Columns</a> </li>
<li id='menu-item-467' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/latest-news/">Latest News</a> </li>
<li id='menu-item-492' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/question-and-answer/">Q&#038;A</a> </li>
<li id='menu-item-468' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/viewpoints/">Viewpoints</a> </li>
</ul>
</li>
<li id='menu-item-25' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/media-kit/">Media Kit</a> </li>
<li id='menu-item-126' class="menu-item menu-item-type-post_type menu-item-object-page" ><a  href="https://deltabusinessjournal.com/business-brief/">Business Brief</a> </li>
</ul>									<!-- /#main-nav -->
									
																		
															</nav>
							<!-- /#main-nav-wrap -->
							
						</div>

																				<!-- /header-widgets -->
						
						<a id="menu-icon-close" href="#"></a>
					</div>
					<!-- /#mobile-menu -->
				
				
				
				
			</header>
			<!-- /#header -->

	        
		</div>
		<!-- /#headerwrap -->
	
	<div id="body" class="clearfix">

		

	
	<!-- layout-container -->
	<div id="layout" class="pagewidth clearfix">

		
		<!-- content -->
		<div id="content" class="list-post">
			
			
				

<article id="post-1484" class="post clearfix post-1484 type-post status-publish format-standard has-post-thumbnail hentry category-special-sections has-post-title has-post-date no-post-category has-post-tag no-post-comment no-post-author   cat-34">
	
            <a href="https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/" data-post-permalink="yes" style="display: none;"></a>
    
	
	
	
		
			<figure class="post-image  clearfix">

									<a href="https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/"><img src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons-275x400.jpg" width="275" height="400" class=" wp-post-image wp-image-1491" alt="Willie-Simmons" /></a>
				
			</figure>

		
	
	
	<div class="post-content">
		<div class="post-content-inner">

							<div class="post-date-wrap post-date-inline">
					<time class="post-date entry-date updated" datetime="2019-06-28">
                                                                                            <span class="year">June 28, 2019</span>
                                            					</time>
				</div>
			
							 <h1 class="post-title entry-title"><a href="https://deltabusinessjournal.com/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today/">How I Made It…  Professionals Discuss How They Got Where They Are Today</a> </h1>			
							<p class="post-meta entry-meta">
					
					
																
									</p>
				<!-- /post-meta -->
			
			
			<div class="entry-content">

				
					<p class="p1">By Angela Rogalski</p>
<p class="p1">What defines “making it” professionally? Is it when you’re at the top of your field of expertise and feel that sense of personal and professional satisfaction? Is it going that extra mile in your career and your peers and superiors recognize your endeavors? Or is a little of both and a lot of support and motivation from your friends and family along the way? Many would say all of the above. In fact, some Delta leaders did just that, plus added their own comments of love and commitment to the people and places where they work and live.</p>
<p class="p1"><img class="alignleft size-medium wp-image-1486" src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Bill-LaForge-200x300.jpg" alt="" width="200" height="300" srcset="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Bill-LaForge-200x300.jpg 200w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Bill-LaForge-100x150.jpg 100w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Bill-LaForge.jpg 533w" sizes="(max-width: 200px) 100vw, 200px" />As president of Delta State University, Bill LaForge enjoys a long history with the school as it is also his alma mater.</p>
<p class="p1">“Growing up in Cleveland and around the Delta State campus had a major impact on my upbringing and certainly influenced my career decisions, including my presidency,” LaForge says. “My mother and father were huge positive influences on me, and provided a nurturing, supportive environment. Delta State was my college of choice, and my father was my academic advisor. So I wound up with the best and toughest professors. Otherwise, he pretty much left me alone to be a typical college student.</p>
<p class="p1">“I enjoyed four terrific years at Delta State, which provided me with a great mix of academics and extracurricular activities, including student government, fraternity life, and athletics. The skills I acquired on this campus have travelled with me throughout my career at every stage. I graduated from Delta State with a feeling of accomplishment and preparedness that served me well in my later pursuits in graduate school and in my career. For me, it all started at Delta State.”</p>
<p class="p1">LaForge stays motivated in his position through a sense of honor and dedication to Delta State and its students.</p>
<p class="p1">“I’ve always been a self-starter, but various types of motivation and inspiration also help fuel my drive. Beyond the honor and privilege of serving the university as president, I feel a sense of service obligation that brings professional gratification and inspires me. I believe in servant leadership, in building quality, in striving for excellence, and in helping to ensure that my alma mater continues to be as successful as possible for many years to come.”</p>
<p class="p1">He adds that everything that has come before in his professional path has helped him as president of DSU.</p>
<p class="p1">“While becoming president of Delta State was certainly a ninety degree turn in my career, essentially everything I have done in my career track helped prepare me for what I am doing today,” LaForge says. “The accumulated experiences I gained at every career stop certainly advise and influence my thinking, actions, and decision-making every day.”</p>
<p class="p1"><img class="alignleft size-medium wp-image-1491" src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons-240x300.jpg" alt="" width="240" height="300" srcset="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons-240x300.jpg 240w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons-120x150.jpg 120w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Willie-Simmons.jpg 640w" sizes="(max-width: 240px) 100vw, 240px" />Senator Willie Simmons has represented Senate District 13, Bolivar, Sunflower and Tallahatchie counties for twenty-six years. Simmons’ political journey began with his involvement in education.</p>
<p class="p1">“In 1975, I was involved in my community’s (Cleveland) civic club organization and they were looking for someone to run for the schoolboard,” Simmons says. “So I ran for the schoolboard and was successful. And because of that, I walked into the political world by helping others and getting elected. And then in 1992, I decided I could make a difference as senator and wanted to run. I thought I could execute change through a more diverse group of individuals with different mindsets. If I could bring my experience and knowledge to the table, maybe we could have change and find an improved path for our political system. I was first elected in 1993.”</p>
<p class="p1">Simmons grew up in Utica, Miss. in Hinds County, where he and his family sharecropped cotton. Growing up in the 1960s, Simmons says he never envisioned himself as a U.S. senator someday.</p>
<p class="p1">“African Americans in Mississippi during those days were not part of the political arena,” Simmons says. “It wasn’t until I finished college that I even considered that an African American could be elected to political office. So, because of that it wasn’t anything I ever dreamed of becoming. It is very rewarding for me to look back and see how far we have come as a country and a state, and how the races have come together to work for the good of the people of Mississippi. That is quite an accomplishment for us all.”</p>
<p class="p1"><img class="alignleft size-medium wp-image-1488" src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mayor-Steve-Rosenthal-199x300.jpg" alt="" width="199" height="300" srcset="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mayor-Steve-Rosenthal-199x300.jpg 199w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mayor-Steve-Rosenthal-99x150.jpg 99w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mayor-Steve-Rosenthal.jpg 530w" sizes="(max-width: 199px) 100vw, 199px" />Mayor Steve Rosenthal of Indianola says in his case it was a dedication to the city of Indianola and its residents.</p>
<p class="p1">“In the mid-2000s, the former mayor and board of aldermen doubled their salaries,” Rosenthal explains. “I felt that if they were doing their job for the money, they were not who we needed running our city. I packed the boardroom for almost a year at every meeting but was unable to get them to reverse the raise. All the members of the board that voted for the raise and the mayor were defeated the next election. The first meeting of my first term my salary was reduced by $12,000.00 dollars.”</p>
<p class="p1">Rosenthal adds that he feels excitement and is galvanized into action by the citizens of Indianola.</p>
<p class="p1">“When I know that I have helped move our citizens up to a better quality of life and improved our city for everyone, that motivates me.”</p>
<p class="p1">As far as envisioning himself as mayor of Indianola in days past, he was always committed to community service, but not really in a highly visual capacity.</p>
<p class="p1">“ I have always worked as a volunteer in my community<span class="Apple-converted-space">  </span>but mostly behind the scenes, so I<span class="Apple-converted-space">  </span>never envisioned city government. I closed the Family Department Store “ Ben Fried’s” in 2002 after three generations and 89 years in business. I knew that I could not just sit around but wanted to make a difference. It is more than I imagined, more work, but much more satisfying than expected.”</p>
<p class="p1"><img class="alignleft size-medium wp-image-1487" src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Chrissy-Garner-TunicaCVB-TreyClark-300x200.jpg" alt="" width="300" height="200" srcset="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Chrissy-Garner-TunicaCVB-TreyClark-300x200.jpg 300w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Chrissy-Garner-TunicaCVB-TreyClark-150x100.jpg 150w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Chrissy-Garner-TunicaCVB-TreyClark.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" />Chrissy Garner is advertising and marketing manager for the Tunica Convention &amp; Visitors Bureau. Garner realized early on that sometimes being in the right place at the right time can lead one to their own destiny.</p>
<p class="p1">“My first real job out of college was at an advertising agency in Little Rock, Ark. in the media department,” Garner says. “I eventually worked my way up to create a media buy for our client, Tunica, Miss. At one point I left that agency, but eventually came back to work as the account executive on the Tunica account. Eventually my agency and the client decided to split ways and almost eleven years ago, I moved to Tunica to become the in-house Tunica Convention &amp; Visitors Bureau marketing manager.”</p>
<p class="p1">Garner adds that staying motivated in her position is easy because she loves her job and finds it very rewarding. “It’s always exciting to know that something you designed or a project you managed influenced or encouraged a visitor to break out of their everyday to visit Tunica.”</p>
<p class="p1"><img class="alignleft size-medium wp-image-1490" src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Jon-Levingston-199x300.jpg" alt="" width="199" height="300" srcset="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Jon-Levingston-199x300.jpg 199w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Jon-Levingston-100x150.jpg 100w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Jon-Levingston.jpg 531w" sizes="(max-width: 199px) 100vw, 199px" />Executive Director of the Clarksdale/Coahoma County Chamber of Commerce, Jon Levingston, was a businessman in Clarksdale for many years and enjoyed the professional and personal relationships that he had cultivated with the citizens. So, being appointed executive director of the Chamber was both an honor and a great fit for him.</p>
<p class="p1">“For thirty years, I had the privilege of managing my family’s business interests in the Delta. I sold our primary business, Levingston Furniture Company in 2012. After working on a variety of projects, including contributing essays to a book about one of Mississippi’s great visual artists, Marie Hull, I was honored to be appointed the executive director of the Clarksdale/Coahoma County Chamber of Commerce and the Economic Development Authority of Coahoma County.”</p>
<p class="p1">As far as his continued motivation where his present job is concerned, Levingston says that one is easy. Put simply, he loves his job.</p>
<p class="p1">“Our region of the state has suffered depopulation for several decades,” he explains. “Depopulation results in fewer resources for our community, including less money in city and county government coffers to repair streets, sewers, to invest in education, and other necessary quality of life investments. Only jobs stop depopulation. Bringing jobs to my community and strengthening Clarksdale economically is a challenge that motivates me every single day. I love that challenge.”</p>
<p class="p1"><img class="alignleft size-medium wp-image-1485" src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Beth-Stevens-200x300.jpg" alt="" width="200" height="300" srcset="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Beth-Stevens-200x300.jpg 200w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Beth-Stevens-100x150.jpg 100w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Beth-Stevens.jpg 533w" sizes="(max-width: 200px) 100vw, 200px" />Beth Stevens is the executive director of the Greenwood-Leflore County Chamber of Commerce.</p>
<p class="p1">“I grew up in Grenada, but moved to Greenwood as an adult,” Stevens says. “I stayed at home awhile, but decided I really needed to get out into the community. My background is in journalism, so I took a job at the newspaper, The Greenwood Commonwealth, as a receptionist since at the time that was the only opening they had. Eventually, I became the Lifestyles editor at the paper and did that for a number of years.”</p>
<p class="p1">Stevens adds that she left the paper and opened a retail store, which she did for a number of years, but ended up going back to the paper in her same position, Lifestyles editor.</p>
<p class="p1">“While I was at the paper the second time, the position of executive director of the Chamber became available,” she says. “I knew it was an interesting job because I had been writing about it for years through events that were happening around town and other activities the Chamber was associated with.<span class="Apple-converted-space">  </span>So, I went and interviewed for the job and I got it and I have been in my present position for fifteen years.”</p>
<p class="p1">Stevens says that everything she did prior to the Chamber only helped her in her current position. “I was so familiar with the Chamber and what they did through my writing about them that it was a great fit for me. And I had been in the community professionally for so many years that I had a relationship with Greenwood and its citizens, so it worked out wonderfully.”</p>
<p class="p1"><img class="alignleft size-medium wp-image-1489" src="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mathews-300x225.jpg" alt="" width="300" height="225" srcset="https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mathews-300x225.jpg 300w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mathews-150x113.jpg 150w, https://deltabusinessjournal.com/wp-content/uploads/2019/06/Mathews.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" />Mathews Film Company originated in Greenville, but has now moved to Oxford, Miss and specializes in commercial, industrial, documentary, and film production. Owner Jamie Mathews is a Greenville native and got into the business through his love of films as a youth.</p>
<p class="p1">“As a teenager, I always wanted to be an actor,” Mathews says. “I was born and raised in Greenville, and after attending Delta State, I decided to move to Los Angeles and started working as an extra in films. I was totally enthralled with the whole idea of filmmaking, all the behind-the-scenes stuff. I worked on a movie with Clint Eastwood; I was an extra for three weeks for him in the movie “Midnight In The Garden of Good and Evil,” and I watched him work, he directed the movie, and I knew that was what I wanted to do.”</p>
<p class="p1">Mathews took a job with an independent production company while he was in Los Angeles, but decided to move back to Greenville in 2001.</p>
<p class="p1">“I slowly started doing production in the Delta, met my wife Heather and got married,” he says. “And in 2007 we both started the company and we’ve been working doing commercials, music videos and documentaries ever since. My wife Heather is our producer, so it’s both of us that made this happen.”</p>
<p class="p1">Mathews says that as far as goals for the company, it’s to be Mississippi’s filmmaker.</p>
<p class="p1">“Not that we’re the only ones who do it in our state, but we do promote Mississippi,” he adds. “And we love doing Mississippi stories.”</p>
<div id="themify_builder_content-1484" data-postid="1484" class="themify_builder_content themify_builder_content-1484 themify_builder">

    </div>
<!-- /themify_builder_content -->
				
			</div><!-- /.entry-content -->

			
		</div>
		<!-- /.post-content-inner -->
	</div>
	<!-- /.post-content -->
	
</article>
<!-- /.post -->

			
			
			
			
			
			
					</div>
		<!-- /content -->

		
		    
    <aside id="sidebar" itemscope="itemscope" itemtype="https://schema.org/WPSidebar">

        
	<div id="search-3" class="widget widget_search"><h4 class="widgettitle">Site Search</h4><form method="get" id="searchform" action="https://deltabusinessjournal.com/">

	<i class="icon-search"></i>

	<input type="text" name="s" id="s" title="Search" value="" />

</form></div><div id="themify-social-links-2" class="widget themify-social-links"><h4 class="widgettitle">Connect On Facebook</h4><ul class="social-links horizontal">
							<li class="social-link-item facebook font-icon icon-medium">
								<a href="https://www.facebook.com/DeltaBusinessJournal/" target="_blank"><i class="fa fa-facebook-square" ></i>  </a>
							</li>
							<!-- /themify-link-item --></ul></div><div id="nav_menu-2" class="widget widget_nav_menu"><h4 class="widgettitle">Quick Links</h4><div class="menu-sidebar-1-container"><ul id="menu-sidebar-1" class="menu"><li id="menu-item-474" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-474"><a href="https://deltabusinessjournal.com/cover-stories/">Cover Stories</a></li>
<li id="menu-item-473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-473"><a href="https://deltabusinessjournal.com/feature-stories/">Features</a></li>
<li id="menu-item-472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-472"><a href="https://deltabusinessjournal.com/viewpoints/">Viewpoints</a></li>
<li id="menu-item-471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-471"><a href="https://deltabusinessjournal.com/latest-news/">Latest News</a></li>
</ul></div></div><div id="mc_mm_widget-5" class="widget widget_mc_mm_widget"><h4 class="widgettitle">Get the Brief</h4><div class='mailmunch-wordpress-widget mailmunch-wordpress-widget-224483' style='display: none !important;'></div></div>
        
    </aside>
    <!-- /#sidebar -->

    
	</div>
	<!-- /layout-container -->



        			</div>
			<!-- /body -->

							<div id="footerwrap"   >

					
					<footer id="footer" class="pagewidth clearfix" itemscope="itemscope" itemtype="https://schema.org/WPFooter">

						
													                            <div class="back-top clearfix ">
                                <div class="arrow-up">
                                    <a href="#header"></a>
                                </div>
                            </div>
                        
						<div class="main-col first clearfix">
							<div class="footer-left-wrap first">
																	<div class="footer-logo-wrapper clearfix">
										<div id="footer-logo"><a href="https://deltabusinessjournal.com" title="Delta Business Journal"><span>Delta Business Journal</span></a></div>										<!-- /footer-logo -->
									</div>
															
															</div>
							
							<div class="footer-right-wrap">

																	<div class="footer-nav-wrap">
																			</div>
									<!-- /.footer-nav-wrap -->
																									<div class="footer-text clearfix">
										<div class="footer-text-inner">
																							<div class="one">Copyright 2018 Delta Business Journal</div>																																	</div>
									</div>
									<!-- /.footer-text -->
															</div>
						</div>

																					<div class="section-col clearfix">
									<div class="footer-widgets-wrap">
																				<!-- /footer-widgets -->
									</div>
								</div>
													
						
					</footer>
					<!-- /#footer -->

					
				</div>
				<!-- /#footerwrap -->
			
		</div>
		<!-- /#pagewrap -->

		
		<!-- SCHEMA BEGIN --><script type="application/ld+json">[{"@context":"http:\/\/schema.org","@type":"BlogPosting","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/deltabusinessjournal.com\/how-i-made-it-professionals-discuss-how-they-got-where-they-are-today\/"},"headline":"How I Made It\u2026  Professionals Discuss How They Got Where They Are Today","datePublished":"2019-06-28T07:40:06+00:00","dateModified":"2019-06-28T07:40:06+00:00","author":{"@type":"Person","name":"deltabus-ca"},"publisher":{"@type":"Organization","name":"","logo":{"@type":"ImageObject","url":"","width":0,"height":0}},"description":"By Angela Rogalski What defines \u201cmaking it\u201d professionally? Is it when you\u2019re at the top of your field of expertise and feel that sense of personal and professional satisfaction? Is it going that extra mile in your career and your peers and superiors recognize your endeavors? Or is a little of both and a lot [&hellip;]","commentCount":"0","image":{"@type":"ImageObject","url":"https:\/\/deltabusinessjournal.com\/wp-content\/uploads\/2019\/06\/Willie-Simmons.jpg","width":640,"height":800}}]</script><!-- /SCHEMA END -->		<!-- wp_footer -->
		

<a href="https://heapanalytics.com/?utm_source=badge" rel="nofollow"><img style="width:108px;height:41px" src="//heapanalytics.com/img/badge.png" alt="Heap | Mobile and Web Analytics" /></a><script type='text/javascript'>
/* <![CDATA[ */
var themify_vars = {"version":"3.3.9","url":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify","map_key":null,"includesURL":"https:\/\/deltabusinessjournal.com\/wp-includes\/","isCached":null,"minify":{"css":{"themify-icons":1,"themify.framework":1,"lightbox":1,"themify-builder-style":1},"js":{"backstretch.themify-version":1,"bigvideo":1,"themify.dropdown":1,"themify-tiles":1,"themify.mega-menu":1,"themify.builder.script":1,"themify.scroll-highlight":1,"themify-youtube-bg":1,"themify.parallaxit":1}}};
var tbLocalScript = {"isAnimationActive":"1","isParallaxActive":"1","isParallaxScrollActive":"1","animationInviewSelectors":[".module.wow",".module_row.wow",".builder-posts-wrap > .post.wow"],"backgroundSlider":{"autoplay":5000,"speed":2000},"animationOffset":"100","videoPoster":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify\/themify-builder\/img\/blank.png","backgroundVideoLoop":"yes","builder_url":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify\/themify-builder","framework_url":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/themify","version":"3.3.9","fullwidth_support":"1","fullwidth_container":"body","loadScrollHighlight":"1","addons":[],"breakpoints":{"tablet_landscape":[769,"1024"],"tablet":[681,"768"],"mobile":"480"}};
var themifyScript = {"lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"lightboxContext":"body"};
var tbScrollHighlight = {"fixedHeaderSelector":"#headerwrap.fixed-header","speed":"900","navigation":"#main-nav","scrollOffset":"-5"};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/js/main.min.js?ver=3.3.9'></script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' defer="defer" src='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/themify/js/themify.sidemenu.min.js?ver=1.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themifyScript = {"themeURI":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra","lightbox":{"lightboxSelector":".themify_lightbox","lightboxOn":true,"lightboxContentImages":false,"lightboxContentImagesSelector":"","theme":"pp_default","social_tools":false,"allow_resize":true,"show_title":false,"overlay_gallery":false,"screenWidthNoLightbox":600,"deeplinking":false,"contentImagesAreas":"","gallerySelector":".gallery-icon > a","lightboxGalleryOn":true},"lightboxContext":"#pagewrap","fixedHeader":"fixed-header","sticky_header":"","ajax_nonce":"9063bd5ba7","ajax_url":"https:\/\/deltabusinessjournal.com\/wp-admin\/admin-ajax.php","smallScreen":"760","resizeRefresh":"250","parallaxHeader":"1","loadingImg":"https:\/\/deltabusinessjournal.com\/wp-content\/themes\/themify-ultra\/images\/loading.gif","maxPages":"0","currentPage":"1","autoInfinite":"auto","infiniteURL":"0","scrollToNewOnLoad":"scroll","resetFilterOnLoad":"reset","fullPageScroll":"","shop_masonry":"no","scrollHighlight":{"scroll":"internal"},"tiledata":{"grids":{"post":{"1":["AAAA"],"2":["BBCC","BBCC"],"3":["DD.."],"4":[".EEF",".EEF"],"5":["DD..","BBCC","BBCC"],"6":[".EEF",".EEF","BBCC","BBCC"],"7":[".EEF",".EEF","DD.."],"8":[".EEF",".EEF","DD..","AAAA"],"9":[".EEF",".EEF","DD..","BBCC","BBCC"],"10":[".EEF",".EEF","DD..","MMNN","MMPP"],"11":[".EEF",".EEF","DD..","MMNN","MMPP","AAAA"],"12":[".EEF",".EEF","DD..","MMNN","MMPP","BBCC","BBCC"],"13":[".EEF",".EEF","DD..","MMNN","MMPP","LSRR","LSRR"]},"mobile":["AA",".."]},"default_grid":"post","small_screen_grid":"mobile","breakpoint":800,"padding":5,"full_width":false,"animate_init":false,"animate_resize":true,"animate_template":false}};
/* ]]> */
</script>
<script type='text/javascript' defer="defer" src='https://deltabusinessjournal.com/wp-content/themes/themify-ultra/js/themify.script.min.js?ver=1.9.1'></script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://deltabusinessjournal.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
	</body>
</html>